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Warranty 2
Tektronix warrants that this product will be free from defects in materials and workmanship for a period of one (1) year from the date of
shipment. If any such product proves defective during this warranty period, Tektronix, at its option, either will repair the defective
product without charge for parts and labor, or will provide a replacement in exchange for the defective product. Parts, modules and
replacement products used by Tektronix for warranty work may be new or reconditioned to like new performance. All replaced
parts, modules and products become the property of Tektronix.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the warranty period
and make suitable arrangements for the performance of service. Customer shall be responsible for packaging and shipping the
defective product to the service center designated by Tektronix, with shipping charges prepaid. Tektronix shall pay for the return of the
product to Customer if the shipment is to a location within the country in which the Tektronix service center is located. Customer shall
be responsible for paying all shipping charges, duties, taxes, and any other charges for products returned to any other locations.

This warranty shall not apply to any defect, failure or damage caused by improper use or improper or inadequate maintenance and
care. Tektronix shall not be obligated to furnish service under this warranty a) to repair damage resulting from attempts by personnel
other than Tektronix representatives to install, repair or service the product; b) to repair damage resulting from improper use or
connection to incompatible equipment; c) to repair any damage or malfunction caused by the use of non-Tektronix supplies; or
d) to service a product that has been modified or integrated with other products when the effect of such modification or integration
increases the time or difficulty of servicing the product.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PRODUCT IN LIEU OF ANY OTHER WARRANTIES,
EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX’ RESPONSIBILITY TO REPAIR OR REPLACE DEFECTIVE PRODUCTS
IS THE SOLE AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY. TEKTRONIX
AND ITS VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF THE POSSIBILITY OF SUCH
DAMAGES.
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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections of the other
component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and Disconnect Properly. Connect the probe output to the measurement instrument before connecting the
probe to the circuit under test. Connect the probe reference lead to the circuit under test before connecting the probe
input. Disconnect the probe input and the probe reference lead from the circuit under test before disconnecting the probe
from the measurement instrument.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult
the product manual for further ratings information before making connections to the product.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it inspected by
qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other property.
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Preface

Preface
TekExpress is the Tektronix’ Compliance Test Automation Framework, developed to support current and future test
automation needs of customers. Developed using National Instruments’ TestStand, TekExpress leverages on the capabilities
of Microsoft .NET framework and Arendar (Test Result Data Management). It is a highly modular architecture that enables
deploying automated test solutions for various serial standards in a relatively shorter time. This release of TekExpress
provides compliance test automation solutions for the Serial ATA Gen 1 and Gen 2 standard.

Options that are available with TekExpress Serial ATA are:

TSG – PHY/TSG/OOB Test Suite

RSG/RMT Tests Suite

Tx/Rx Tests Suite

TekExpress SATA Bundle for Host and Drive Test Suite

SI Cable Tests for TekExpress SATA

Key Feature
Ease of Connectivity: TekExpress enables compliance test automation and supports various connectivity options such as
GPIB, Ethernet, Serial, and USB for easy connectivity using TekVISA. The Instrument discovery process feature makes it
easier than ever to connect the instrument on TAN. The application will automatically discover all instruments and other
devices connected on TAN.
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Preface

Documentation
This manual describes the basic installation and operation of the TekExpress application. For more detailed information, see
the online help and installation manuals. The following information is available for this product:

TekExpress Serial ATA Online
Help, English

076–0096–xx

Start > Programs >Tektronix >TekExpress >
TekExpress SATA > Help

TekExpress Serial ATA User
Manual, English (PDF)
TekExpress Serial ATA Quick
Start User Manual, English
(PDF)

077–0044–xx

071–2298–xx

C:\Program Files >Tektronix >TekExpress >
Documents

TekExpress Serial ATA
Installation Manual, English
(PDF)

071–2268–xx

Software Upgrades
Periodic software upgrades may become available.

To check for upgrades:

Go to the Tektronix Web site (www.tektronix.com/software).

Enter the product name (TekExpress).

TekExpress™ Serial ATA Quick Start User Manual v
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Install the Application

Install the Application
The TekExpress application must be installed on a computer or on a Tektronix oscilloscope.

Before Installation
Refer to the TekExpress Serial ATA Automated Compliance Solutions Installation Manual to find out about the
prerequisites.

Read the Readme.txt file on the product software DVD.

Installation
1. Close all applications.

2. Insert the product software DVD into the DVD-ROM drive of the computer or oscilloscope.

3. The installation wizard will guide you through the installation. For information on installation, refer to TekExpress
Serial ATA Automated Compliance Solutions Installation Manual.

4. The software files will be installed in C:\Program Files\Tektronix\TekExpress.

Starting the Application
To start the software do one of the following:

From the Start menu, select Start > Programs > Tektronix > TekExpress >TekExpress SATA.

Double-click on the desktop.

Closing the Application
To close the application, do either of the following:

Select File > Exit.

Click .

Using other methods to exit the application will result in abnormal termination.

TekExpress™ Serial ATA Quick Start User Manual 1
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Using TekExpress Application

Using TekExpress Application

Process Flow
Follow steps 1 to 6 to select and run a test to check for compliance. Details for each of these actions are given on
the following pages.

1. Select a device.

2. Select the test suite, choose the version.

3. Select the test.

4. Configure the test parameters.

5. View and select connected instruments.

6. Run the test.

7. View the progress of analysis.

8. View and print the generated report.

Select a Test
1. Select a Device type.

2. Select the Test Suite.

3. Choose the version of the selected test
suite from the Version drop-down list.

4. Select the test you want to run.
You can select multiple tests from the list.

5. To select all the tests in the list, click
Select All.

6. To select only the mandatory tests, click
Select Required.

7. Click Deselect All, to disable the tests.

8. To see the Method Of Implementation of
the selected test, click Show MOI.

9. To see the schematic diagram of the test
setup, click Show Schematic.

TekExpress™ Serial ATA Quick Start User Manual 3



Using TekExpress Application

Configure the Test(s)
1. Highlight the test you want to configure

by clicking the test name.

2. Click Configure.

3. If multiple instruments are connected,
choose the correct instrument from the
drop-down list in the general parameters
tab.

4. Verify schematic related parameters
such as Channel of the Oscilloscope.

NOTE. The default setup is according to
the schematic provided with the test suite.
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Using TekExpress Application

5. You can also change miscellaneous
parameters such as BIST-L Initialization
by.

NOTE. General parameters are common
to all tests, and can be edited even in
the Compliance Mode. However, cells
that are grayed cannot be modified in the
Compliance Mode.

You can generally use the default
settings in Compliance Mode.

6. To configure the test parameters, select
User Defined Mode.

7. Click the Acquire tab to edit parameters
related to acquisition.

8. Click the Analyze tab to edit Analysis
parameters.

TekExpress™ Serial ATA Quick Start User Manual 5



Using TekExpress Application

9. View the measurement limits in the
Limits tab.
Refer to the Online Help for various test
limit comparisons.

10. You can enter test related comments in
the Comments tab.

NOTE. If you want to change the settings
to default, click Restore. This option will
restore the settings to Compliance Mode.

11. Click Apply.
Use the File Menu to Save the session.
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Using TekExpress Application

View and Select Connected Instruments
1. Click Tools > Instrument Bench.

2. Select any of the Search Criteria.

3. Enter the time in seconds in the TekVISA
Refresh Timeout field.

4. Click Refresh.

5. The results of the instrument search are
displayed in the Retrieved Instruments
table.

6. Click Close.

TekExpress™ Serial ATA Quick Start User Manual 7



Using TekExpress Application

Run the Test
7. Enter the ID of the Device to be tested in

the DUT field.

8. Click Run to run the test.

View the Progress of Analysis
9. When the tests are running, the status

and progress of the tests are displayed in
the Analyze tab. The application checks
to see if the device has passed the test.

10. The Status Messages window time
stamps all runtime messages and
displays them.

8 TekExpress™ Serial ATA Quick Start User Manual



Using TekExpress Application

View the Report
You can generate and print a detailed report as described here.

1. After you have successfully run one
or more test(s), a report summary is
generated in HTML format.

2. To save the report summary in the
desired location, select File > Save
Report As.

TekExpress™ Serial ATA Quick Start User Manual 9



Using TekExpress Application

3. To preview the report before printing,
select File > Print Preview Report.

4. Select File > Print Report.
NOTE. Select View Scorecard to view the
test result in standard specific format.

10 TekExpress™ Serial ATA Quick Start User Manual
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Application Examples

Testing a Drive for Compliance
This test verifies that the SATA Gen1 Drive device will receive a 1.5 Gbps stressed data pattern without receive errors.

The following equipment is required to set up the DUT:

Resource Model Supported
Signal Source Tektronix AWG7102 (Option 6)
Real Time Oscilloscope Tektronix DPO/DSA 72004, DPO/DSA 71604,

DPO/DSA 71254, TDS6154C, TDS6124C

For Gen1– only testing, the following scopes are also
acceptable: DPO/DSA 70804 or TDS6804B

RF Switch Keithley S46
Frame Error Analyzer Crescent Heart Software SATA II probe adapter
Test Fixture Crescent Heart Software Fixture TF-SATA-NE-XP,

TF-SATA-FE-XP
DUT A SATA Drive to test

TekExpress™ Serial ATA Quick Start User Manual 11



Application Examples

1. Connect the DUT to the equipment as
shown in the connection diagram.

2. Select Drive as the device type.

3. Select RSG as the Test Suite.

4. Select SATA Gen 1 as the test suite
version.

5. Enter the DUT ID in the DUT field.
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Application Examples

6. If you want to verify the test setup before
running the tests, click Show Schematic.

7. Select RSG-01 – Gen 1 (1.5 Gb/S)
Receiver Signalling Group.

NOTE. RSG-01- Gen 1 (1.5 Gb/Sec)
Receiver Signalling Group will be a
compliance test which is a mandatory test.

8. To view the Method of Implementation
for the RSG test, click Show MOI in the
application.

9. Click Configure to open the
Configuration panel.

10. You can generally use the default values
in the Compliance Mode.

11. Click Close.

12. Click Run to run the test.

TekExpress™ Serial ATA Quick Start User Manual 13



Application Examples

13. Observe that only the RSG-01– Gen 1
(1.5 Gb/S) Receiver Signalling Group
is checked for compliance. Other tests
are skipped. The status of the tests
is displayed in the Status Messages
window.

14. Click Save Status to save the status
messages.

15. When the tests run successfully, a report
appears in the Report panel.
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Application Examples

Testing a Host for Compliance
This test verifies that the SATA Host device will receive a 3.0 Gbps stressed data pattern without receive errors.

The following equipment is required to set up the DUT:

Resource Model Supported
Signal Source Tektronix AWG7102 (Option 6)
Real Time Oscilloscope Tektronix DPO/DSA 72004, DPO/DSA 71604,

DPO/DSA 71254, TDS6154C, TDS6124C

For Gen1- only testing, the following oscilloscopes are
also acceptable: DPO/DSA 70804 or TDS6804B

RF Switch Keithley S46
Frame Error Analyzer Crescent Heart Software SATA II probe adaptor
Test Fixture Crescent Heart Software Fixture TF-SATA-NE-XP,

TF-SATA-FE-XP
DUT A SATA Host to test
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Application Examples

1. Select Host as the device type.

2. Select RSG as the test suite.

3. Select SATA Gen 2 as the test suite
version.

4. Connect the DUT to the equipment as
shown in the setup diagram.

5. To verify the test setup before running
the tests, click Show Schematic.

6. Select RSG-02 - Gen2 (3.0Gb/s)
Receiver Signalling Group.

NOTE. RSG-02 - Gen 2 (3.0 Gb/s)
Receiver Signalling Group is a compliance
test.

7. Click Configure if you want to
configure the test parameters in the
Configure panel.

16 TekExpress™ Serial ATA Quick Start User Manual



Application Examples

8. The general parameters that are not
grayed are editable. To change the
instrument related values, select from
the drop-down list for each of the
parameters.

9. You can use the default values in the
Compliance mode.

10. Click Close.

11. Enter the DUT ID in the DUT field.

12. Click Run to run the tests.
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Application Examples

13. Observe that only RSG-02 – Gen
2 (3.0 Gb/S) Receiver Signalling
Group is checked for compliance.
Other tests are skipped. The status
of the tests is displayed under Status
Messages window.

14. When the tests run successfully, a
report appears in the Report panel.
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